in

Dot Net Mafia

Group site for developer blogs dealing with (usually) Ionic, .NET, SharePoint, Office 365, Mobile Development, and other Microsoft products, as well as some discussion of general programming related concepts.

Kyle Kelin on .Net

The .NET Framework version 4 cannot be installed because the .NET Framework version 1.0 is already installed on your computer

I ran into this error message while trying to install the .NET Framework 4.0 Beta. I went into Programs to remove it and it wasn’t listed. Hmmm. So the first thing I did was download this tool:

http://www.raymond.cc/blog/archives/2008/11/06/how-to-check-what-version-of-microsoft-net-framework-is-installed-in-computer/

Run in and it will tell you which versions of the .NET Framework you had installed. Sure enough 1.0 was listed. So a quick google search brought me to this tool that removes versions of the .NET Framework.

http://cid-27e6a35d1a492af7.skydrive.live.com/self.aspx/Blog|_Tools/dotnetfx|_cleanup|_tool.zip

 

Just a quick note that this comes with no warranty. It worked for me but the cleanup tool is messing with the Registry so do so at your own risk.

Comments

 

[.Net Framework 4.0 Beta 1 Kurulumu / Kar????la????lan Hatalar ve ????z??mleri] | Mehmet ??zakan said:

Pingback from  [.Net Framework 4.0 Beta 1 Kurulumu / Kar????la????lan Hatalar ve ????z??mleri] | Mehmet ??zakan

November 26, 2011 3:22 AM

Leave a Comment

(required)  
(optional)
(required)  
Add

About KyleKelin

Kyle Kelin has been implementing software in the Microsoft space for the past 6 years mainly as a consultant. His interests are SharePoint, .NET, JQuery, and Silverlight.
2018 dotnetmafia.
Powered by Community Server (Non-Commercial Edition), by Telligent Systems